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System Requirements

-  Windows 95, 98, ME, 2000, XP or NT

- 64 Meg Ram minimums, 256 Meg recommended

-  Pentium processor. (Requires a fast system)

-  Printer driver installed and set to default (or error may occur)

Installation

Create a directory on your hard drive called Surfer3D then unzip the ZIP
files provided into that directory.

Next create icons to the main program Surfer 3D:  On your desktop, right-
click the mouse and select New > Shortcut command.  Select the Browse
button and pick the Surfwin.exe file. 

(Note: We will have a real installation program soon.)

 Software Hacking

Each copy of Surfer3d contains the encrypted name and user id of the
customer embedded into the code in numerous places. Hacked programs
can be traced back to the customer who purchased it.

All files created by surfer contain id of the user as well as other
information can be used for tracing.

Copyright Notice
No part of this publication may be reproduced mechanically or in any form
without the prior written permission of Larken Automation Inc. The
software described in this manual is furnished under license and may only
be used or copied in accordance with the terms of such license. The
information in this manual is for informational use only, is subject to
change without notice and should not be construed as a commitment by
Larken. Larken assumes no responsibility or liability for any errors or
inaccuracies that may appear in this document. Star CAM is a registered
trademark of Larken Automation Inc.

© October 2003, Larken Automation Inc.



What is Surfer 3D

Surfer 3d is a program to create 3d tool paths for 3d machining of molds,
models, signs and other parts that cannot be made by standard 2d
machining

A wire frame design is usually created in a CAD program or 3d modeling
program such as AutoCAD (tm), Rhino 3d, 3D studio, Corel Dream3d,
Design Cad 3d or other Cad program. The design must be made up of 3d
polygon surfaces and not single lines and arcs. The drawing should be
shade-able within the Cad program.

The design is then exported from the cad program in the DXF format to a
file and then imported into Surfer 3d. Any number of surfaces can make up
the final design and surface intersections are not a problem.

The drawing size can then be adjusted if necessary. The position of the
drawing is adjusted to where the tool path will be in the correct coordinates
and range for the machine that is to do the cutting.

The desired job resolution is then set considering required finish, cutting
time and file size.

   

The tool paths are then created for roughing and finish paths. These are saved to disk
as files where they can then be sent to the machines controller as required.



Memory Allocation

Surfer uses ram for storage of the drawing data that you load from a DXF file or bitmap. 

Surfer also requires a lot of ram memory to create a digital image of total 3d surface
before it creates a tool path. This is called the surface map (or surface skin). The skin
memory size requirement depends on the size of the part to be cut and the resolution
(detail accuracy) of
the job.If the job is
40" x 60"  (XY)
and you require a
resolution accuracy
of 0.01" then it
would need 4000
data points in the X
axis and 6000 in the
Y axis. Each data
point uses 2 bytes
so the required ram
would be X * Y * 2
or 48,000,000 bytes
or 48 Meg.

Generally set the memory setting to 50-75% of Ram memory.  Don't use the virtual
memory size in windows because it is very slow. The memory is used in blocks of 64K.
Save the config file and reload surfer for the setting to take effect.  

This memory block setting is at the start of the 'Surfer.Cfg' file so if surfer won't load
because you set the memory too high, you will need to Edit the  'Surfer.Cfg' file with 'Note
Pad' and reset it to a small number (150) again. 

How much ram you set to be used by the surface skin depends on the physical memory in
your computer and the dxf or bitmap file sizes you will be using, so the two parts of the
program share the ram proportionally.

Other settings allow you to use different screen background colors and Unit of measure.
The rotation angle is the amount that the drawing turns on each click of the XY and Z
view rotating icons.



       

Step 1 Import DXF

Using the Import command in the file menu, import a dxf file

Step 2 Edit if necessary

Using the Layers dialog you can scale, move and rotate each layer. Also using the
edit menu you can flip the object in the x, y and z.

 Step 3 Zero out the part

Using the Zero Out command in the edit menu, Surfer shifts the part to the proper
position to create a tool path. It moves the part into positive xy coordinates
starting at 0,0 and moves the Z into negative with the top of the part positioned at
0.

 Step 4 Set Work Blank

This lets you define a boarder around the part so the tool can clear the part on the
edges. It shifts the part according to boarder size.

Step 5 Set the Z limits  (optional)

Use the 'Z-cut Level' icon to set the lower cutting limit.  This sets the maximum
depth that the tool will cut into the material and other parameters.

Step 6 Create Tool Paths

Use the Tool path dialog to create the desired tool path(s)

 Importing your DXF or STL file

Use the Import DXF command in the file menu to load the DXF file. Surfer
displays the number of entities found on the status line as it is loading.  Before
importing, set a layer in the layer menu to 'Live' to specify which layer to import
into. (See Layers)

   The STL format can also be imported (ascii STL format only). This is the format
used for Stereo Lithography, a process for creating 3d prototype parts from resin .

    



What is DXF?

Drawing EXchange Format

DXF is a file format created by AutoCAD tm for exchanging drawing data
between cad programs. The file can contain many types of drawing entities such as
Lines, Circles, Arcs, Text, Dimensions and also 3d wire frame surfaces.  Surfer 3d
only extracts the 3d surfaces from the DXF file.

Surfer reads in the 3d Polyline Mesh, 3d Face, and 3d Polyface Mesh entities. All
other objects are ignored by surfers import routine.

The simple test whether you will be able to use Surfer to create tool paths on your
AutoCAD drawings is to use the Shade command in AutoCAD. If you can Shade
it, Surfer can machine it.

Sample DXF file

(This is part of a sample of a DXF file.)

0

ENTITIES

0

POLYFACEMESH

8

LAYER1

6

CONTINUOUS

0

VERTEX

8

LAYER1

6

CONTINUOUS

10

-0.0000

20

-0.0000

304.0000



Working with Layers

Your surface data that you import into Surfer can be separated into layers for better
control and selection of your drawing. Different objects can be loaded in to
different layers and this allows you to move, edit or hide objects. Some commands
for modifying a certain object such as molding one layer on top of others, requires
you to select a layer to be the one modified and
others to be the modifiers. 

Layer Status

Each layer has a status column that you can set to
one of four setting. Off, Cold, Hot or Live. 

  

Off     - Hides a Layer from all create, modify or
edit commands. Also not exported

Cold  - The Layer is displayed, but cannot be 
modified.  It will be exported

Hot    - Layer can be modified, edited and all
others

Live   - Same as Hot but is the selected Layer for
commands that require a layer to be selected.
Only one layer can be live

Layer Type

The Type column shows whether the layer contains 3d surface faces or vector
contours. The program sets this column when you import data. You can't mix data
types within a layer.to change the Layer name, Double click on the name to
highlight it.

Moving, Scaling etc

You can modify surfaces sung the Layers menu. Each surface can be put on a
separate layer and then it can be moved, resized rotated, copied and deleted.  You
can also edit the name of the layer.

Using the layer menu to modify objects instead of direct on-screen mouse editing is
a much more accurate and controllable method. Selecting objects in 3d with a
mouse is not easy.

Select the layer you want to work with by setting its status ‘Live’. (Clicking on the
column just left of the layer name will set it Live.)   Then click on the appropriate
edit button, Scale move etc.

Make the changes and the select 'Apply'. You will see the results immediately on
screen.  Also you can use the Zoom icons to select the view angle while using the
Layer edit buttons.



Zoom Icons

Zoom icons are active for all commands. You can even zoom while commands such
as tool path create are in progress

Dragging with the right mouse button pressed down can also do rotating. 

Move side to side with the mouse for X-Y or up/down for Z.

Zoom Popup menu

Click the right mouse button to activate the Zoom sub-menu 

Defining Tools

Surfer 3d allows you to use to use any diameter and 4 different standard tool shapes
to machine your part.

Selecting the Tool List command from
the Tool path menu brings up the tool
list.

Defining a New Tool

 Up to 30 different tools can be defined.  To
create a new tool click the New tool button and enter
a Name for it (max 20 chars). Then select it from the
tool list with the mouse. Select the Cutter type, and
then enter the Diameter and other parameters that
the tool shape requires. The Maxcut/pass is the
depth of cut that the tool can cut in one pass. This is
used by the multipass function in roughing. Double
click on Update Tool to define the setting to the new
cutter. Select the Save tools to save your changes to
disk.



Cutter types

Most 3d modeling is done with a Ball nose cutter since it leaves the smoothest profiles, but
the other types have special purposes such as the Conical and Flat conical cutters are good for
engraving on 3d surfaces and giving detail.

 

Cutter Sizes It is important in Surfer 3d to use cutters with diameters which have a

common divisor.   There is a direct relationship between the base resolution and the cutter
diameters. The base resolution must be an exact fraction of all cutters used in the job.

EG:  if you are using 1/2”, 1/4” and 1/8" cutters then the job resolution
could be 1/16”, 1/32”, 1/64" or 1/128” It couldn’t be 1/50"The same goes
for metric. For cutter diameters of 2mm 4mm 5mm etc, you could have a
job resolution of 0.25 mm 0.5 mm or 1mm etc. You cannot use   2.1 mm
4.3mm and 5mm cutters since there is no common divisor.

Adjusting Orientation You can use the Flip commands in the Edit menu to rotate the job so you

can machine the correct surface.  Also use the Mirror Z command to invert
the Z values.

The Icons for adjusting and setting up your drawing position are arranged in
order from left to right.

     

Adjusting the Position   Before you create the tool path, you must position your 3d objects in the

positive quadrant with the top of the object at the zero in the z-axis.

Use the Icon or the Auto adjusts position command in the Edit menu to do
this.  Note the position of the 0,0,0 point gets raised to the top corner of the
objects.

Defining the Work blank To make it easier to position the objects on the screen for machining, you
can define a work blank (the piece of material that you will cut the objects



out of). Use the Define Work Blank command in the Setup menu and enter
the width (x), height (y) and thickness (z) values. Also first set whether you
are working in inches or millimeters.

The work blank will then be shown with the drawing to allow you to
visually position the objects easier.

Z Level Dialog

The Z level dialog lets you define a number of parameters associated with Z depth

Single Level Job

This should be selected for jobs that can be cut completely on your router. This
setting is more commonly used than multi slice cutting.

Setting Multi Slice cutting

This allows you to cut a tall model into slices so you can cut them on a
lower milling CNC router.  Models with hollow
center areas need special attention when cut this
way.

Select the 'Slice to different levels'   check box
and set the depth of slice. Then select the slice
number to cut and cut them in succession.

 Holding the Workpiece for this type of
job can be a bit of a challenge.

Uncovered Area

Some DXF meshes are not rectangular and the mesh doesn't cover the full area of
the work piece. This lets you define the uncovered area to be left high, or cut to the
bottom. 

This is useful when making a negative mold of an object such as the inside of a
facemask. You want the area around the cavity to be not cut and left high. So you
would set this to set as upper level.

Tool path dialog



To create a tool path you use the Create tool path command in the Tool path menu.

This dialog box holds all settings required for defining a tool path.

The first thing you should do is set the base resolution for the project. This is a
setting that you decide upon at the start of creating your tool paths and you don't
change.  It determines the accuracy of the project. 

Base Resolution 'defined'

The base resolution is the sampling distance in x and y that the program uses to fit
the tool bit into your objects as it moves along the tool path.

Digital Sampling limitations

Surfer 3d is a digital program. Similar to the way digital audio is sampled at 44,000
times per second, its possible that the audio sampler misses some audio that is
between sampling periods, surfer samples your object in a fixed grid (defined by the
base resolution) and some very fine 'needle spikes' in the object could be missed.
BUT: needle spikes couldn't be machined anyway since the cutter is much bigger
and the end radius couldn't produce the detail.

Create Tool Path

You can create one tool path at a time for roughing and finish passes and save each
to a file.

1) The first thing you should do is set the base resolution for the project. This is a
setting that you decide upon at the start of creating your tool paths and you don't
change.  It determines the accuracy of the project. 

2) Select the desired cutter, depending on whether this will be a roughing or finish
pass.

3) Select the tool path type, whether you need roughing or a finish pass.  If its set
for roughing the cutter will multipass automatically using the maximum cut per pass
setting of the tool as set in the Tool List. You can also set an amount for the rough
pass to leave.

4) Select the Step over amount. This is the amount that the cutter moves over in the
on each  "swath" of the tool path. This parameter is defined in units of base
resolution.  EG: if you are roughing and want to remove a lot if material with out



wasting a lot of time, you could set the step over to almost the diameter of the
cutter.  For most finish cuts you would leave the step over at 1. For roughing you
can set it almost as wide as the cutter.

5) Click on the Filename button and enter a file name. Surfer will create the Larken
LKF file type that you can load into Lcam

6) Select the Create tool path button. You should see the lines being drawn over
the objects.

The program will first create the tool skin as defined by the base resolution. It will
then create the tool path.    If additional tool paths are required and the drawing
hasn't been modified, surfer will not have to recreate the tool skin, which saves a lot
of time.

  Roughing Passes

For roughing passes surfer will remove the excess material using multipass cutting

It will go back and forth on each swath and lower the tool using the Cut/pass
setting defined in the tools definition (Tool List command)

When roughing you can set the Step over parameter to a value close to the cutter
diameter to rapidly remove material.  

Note: When roughing with the step over set higher than 1 the program always
prevents the roughing cutter from gouging or removing detail between swaths. The
border width should be at least the width of the cutter to allow a safe swath-to-
swath step over area.

 Finish passes



The finish pass setting disables multipass and cuts the object assuming that the cut
will be light and won't require multipass.

Finish pass tool paths are generally done with a small diameter cutter to give
improved detail and the step over is normally set to 1 for maximum detail

File sizes can be very large. Use PKzip to compress files so the will fit on a disk if
necessary. Also networking design and control computers may be required.

 Loading into LCAM or StarCam

Use the Load command or Import LKF command to load into Lcam. To view in 3d
use the Zoom menu and select 3d Mode

There is 3d scaling and Z scale and Z shift commands in the Edit menu under
More editing.   The Z shift command allows you to shift the surface up or down in
the Z-axis.



3D Vector Surfer 3d allows you to fit 2d contour graphics to 3d surfaces for engraving and 3d contour
cutting.  The 2d graphics are imported using the 'Import 2d vector Contour' command in the File menu.

 Importing 2D contours

Before importing set an unused layer in the layer menu to 'Live' to hold the
contours.   The import command reads only Lines from the DXF file so it may be
necessary to explode arcs to lines with your exporting program.

 Position the contours

Use the Layers menu to scale and move the contours over your surfaces. The z
position is not important since Surfer will control the Z coordinate when it forms
the contour to the surfaces.

You can use the zoom icons while moving to view your objects from Top and sides
to help set the position.



Use the Set Work Blank command to define the work area.

Set the vector layer that you want to 'form' to ‘Live’.  Use the 'Form Vector Path'
command in the surfaces menu to form the path.

Use the 'Output Vector Tool Path' command in the Tool path menu to output all
vector Layers in Gcode format. Turn off vector layers that you don't want to
export. 

        



Bitmaps to Surfaces

Surfer can convert bitmap files (.BMP) to surface meshes using the gray level of the
picture as a Z level. Use the Bitmap Import/Convert command in the file menu to
bring up the bitmap box. Note: Your graphic display settings must be in 24-bit
color for this command to work properly.

Ideal Bitmaps

Simple bitmap pictures and patterns work best for converting. Results for
photograph type pictures will be unpredictable due to shadows, and gray levels
don't necessarily translate to the desired Z depth that a hand carving would have.
Bitmaps can work well for pattern generation of textures and backgrounds for your
sign or project.   

Bitmap Size

Large bitmaps create a huge amount of data and slow the program down. A 640-
x480 bitmap has 307200 pixels.  Since each pixel generates a 3d face, this can
create a very large amount of data!  Also since you can scale the surfaces to any
size, a small bitmap can create a large sign.

Convert to Grayscale

After loading a .BMP file from the File menu Load command, you should see the
picture on the screen. Use the convert to Grayscale command in the Edit menu to
convert the picture to 256 levels of grayscale. The Undo command undoes all
modifications and refreshes the picture to original.

Smoothing and Adjustments

The smooth command averages transitions between z levels giving a less jagged
result. You can smooth repeatedly to get the desired result.

  

Show Spectrum This shows you the amounts of shades and distribution of
depths in the bitmap. Try some commands like 'Compress' and see the effect using 
'Show spectrum'



Bitmap Effects

Scanned images and bitmap graphics from paint programs can produce small signs
and carvings. These can also be added and fitted onto dxf cad drawings 

The Smooth command creates a smooth transition between z levels in the bitmap
that produces a flowing effect



Other CAD Programs 

Rhino3d

Rhino 3d is one of the best 3d Cad programs you will find. It works very well with
Surfer 3d using the DXF export command.  Select your objects to export, then go
to the File_Export command and select the DXF file type.

 Set the settings in the export menu as shown below. 

You will be asked to set the mesh density next. Generally a mid setting for this
should work ok, but you can go finer for a better finish.

We highly recommend getting rhino to use with surfer.  There website is
www.rhino3d.com. Also check out www.dvdirect.com for a better price on rhino

AutoCAD

Use the DXFOUT command to export. See the description of DXF format for
supported entities.  Select version 12 or 13, but not 14 since AutoCAD has changed
the DXF in version 14.

 

Design Cad 3d

Design Cad 3d works well also using the Export DXF command. 
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